AutoForm System Requirements

AutoForm software is available on the following platforms.

AutoForm Forming R8

Components Available Platforms

Front-End Components
(AutoForm User Interface
and Front-End Modules)

Windows 7 64 bit
(Professional, Ultimate, Enterprise),
Service Pack 1

Windows 10 (Pro, Enterprise)

Windows Server 2016

Back-End Components
(Solver)

Windows 7 64 bit
(Professional, Ultimate, Enterprise),
Service Pack 1

Windows 10 (Pro, Enterprise)

Windows Server 2016

Linux 64 bit *

License Server (RLM)

Windows 7 64 bit
(Professional, Ultimate, Enterprise),
Service Pack 1

Windows 10 (Pro, Enterprise)

Windows Server 2016

Linux 64 bit *

  • Only for x86-64 microprocessor architectures. Requires GNU C library glibc 2.5 or higher and in addition SUSE Linux Enterprise Server 11 or 12, openSUSE 42, Red Hat Enterprise Linux 5, 6 or 7.

All Windows platforms:

  • Supported on x86-64 microprocessor architecture only.
  • AutoForm R8 setup needs .NET 3.5 Client Profile.

AutoForm Hydro 2016

Components Available Platforms

Front-End & Back-End Components

Windows 7 64 bit
(Professional, Ultimate),
Service Pack 1*

License Server (FlexNet Publisher)

Windows 7 64 bit
(Professional, Ultimate),
Service Pack 1*

Linux 64 bit **

  • Only for x86-64 microprocessor architectures.
  • Only for x86-64 microprocessor architectures. Requires GNU C library glibc 2.3, Standard C++ library libstdc++.so.5 and in addition SUSE Linux Enterprise Server 10, openSUSE 10 or 11 or Red Hat Enterprise Linux 3, 4 or 5.

CAD Embedded Modules R8

Components Available Platforms

CATIA-Embedded Products

CATIA V5R21, V5R22, V5R23, V5R24, V5R25, V5R26, V5R27 and V5R28

Windows 7 64 bit
(Professional, Ultimate, Enterprise),
Service Pack 1

NX-Embedded Products

NX 9.0, NX 10.0, NX 11.0 and NX 12.0

Windows 7 64 bit
(Professional, Ultimate, Enterprise),
Service Pack 1

License Server (RLM)

Windows 7 64 bit
(Professional, Ultimate, Enterprise),
Service Pack 1

Windows 10 (Pro, Enterprise)

Windows Server 2016

Linux 64 bit *

  • Only for x86-64 microprocessor architectures. Requires GNU C library glibc 2.5 or higher and in addition SUSE Linux Enterprise Server 11 or 12, openSUSE 42, Red Hat Enterprise Linux 5, 6 or 7.

All Windows platforms:

  • Supported on x86-64 microprocessor architecture only.
  • AutoForm R8 setup needs .NET 3.5 Client Profile.

Contact AutoForm Engineering

Do you have any question? Would you like to contact us? Please fill in the form below (fields marked by * must be completed in order to send this form).

Contact AutoForm Engineering

Thank you very much. Your request has been successfully sent.